Problème de pilote FTDI FT232RL sur prusa I3 et carte MELZI2.0

Publié le 24 Janvier 2016

Aujourd'hui en essayant une impression via Repetier sur mon PC W10 x64 : gros problème.

La carte interface USB a base de chip FTDI FT232RL n'est plus reconnue.

Une recherche sur internet me donne des tas d'infos sur les faux chips FTDI qui sont bloqués par une mise à jour de pilote, est-ce cela qui m'est arrivé ?

Comment mettre évidence le problème :

Lorsque la prusa I3 est interrogée via un moniteur série :

- installer Une version du compilateur Arduino (V1.6.7 dans mon cas)

- connecter et allumer la prusa si c'est pas encore fait

- dans arduino/outils : choisir le port COM de la prusa

- ouvrir outils/moniteur série

Si vous avez le message "non genuine device found" : vous êtes dans la merde comme moi...

Problème de pilote FTDI FT232RL sur prusa I3 et carte MELZI2.0

Attention : le bricolage peu rendre la solution encore pire : vous faites çà à vos risques et périls ...Il y a 3 solutions :

- changer de carte Melzi : bon on oublie celle-là

- travailler sous Windows XP ou linux : sur mon vieux PC Pentium3 sous XP : aucun problème rencontré avec repetier

- Désinstaller votre pilote actuel, interdire à windows de mettre à jour les pilotes, forcer l'installation d'un vieux pilote (FTDI_drivers_2.04.06)

La dernière solution semble marcher pour moi mais m'a fait perdre la moitié du WE !!!!

Quelques captures d'écran :

Interdire les MAJ automatiques de pilotes

Interdire les MAJ automatiques de pilotes

Désinstaller ces 2 lignes (cocher supprimer le pilote, bien que Windows ne le fait pas vraiment : supprimer les fichiers manuellement dans system32 si çà veut pas)

Désinstaller ces 2 lignes (cocher supprimer le pilote, bien que Windows ne le fait pas vraiment : supprimer les fichiers manuellement dans system32 si çà veut pas)

Et pour forcer l’installation c'est aussi dans le gestionnaire de périphérique ... il faudra peut-être redemarrer ou débrancher puis rebrancher l'USB

Il y a différents problèmes qui se ressemblent : mon Product ID est bon 0x6001

et difficile de différencier le vrai du faux FT232 : http://hackaday.com/2014/02/19/ft232rl-real-or-fake/

Outil de test : http://www.eevblog.com/forum/reviews/ftdi-driver-kills-fake-ftdi-ft232/?action=dlattach;attach=193941

Liens :

Page très intéressante sur la carte Melzi (dont une partie FTDI problem) : http://reprap.org/wiki/Melzi

Page avec le lien vers l'ancienne version du pilote "FTDI_drivers_2.04.06" : http://www.wizard-from-oz.com/usb-communication-problem-ftdi-ft232r-1213-c-bug-and-workaround/​

Forum qui parle du probleme : http://hackaday.com/2014/10/24/ftdi-screws-up-backs-down/#comment-2059852

Autre page pour aider (pas testé) : http://forums.reprap.org/read.php?1,417199,418768#msg-418768 ou https://ljck.org/unbrick_ftdi ou une vidéo : https://www.youtube.com/watch?v=SPdSKT6KdF8

Tant qu'on est dans les problème : page pour le problème de prise USB dé-soudée /arrachée : http://forums.reprap.org/read.php?4,239276

Rédigé par cyril50

Publié dans #Informatique

Commenter cet article

like 26/01/2016 18:21

Salut, j'ai eu un probleme du meme genre je ne sais pas si c'est exactement la meme chose mais l'imprimante n'etait plus reconnue par le pc sans raison. Je me suis apercu que dans les reglages de la machine, le baudrate n'etait plus bon (la machine etait reglee sur un baudrate enorme et ce n'etait pas moi qui l'avait modifié) et changer le baudrate pour le remettre a sa valeur par défaut n'y changeait rien car la machine reboot lorsqu'on la branche au pc.

Pour regler le probleme j'ai simplement changé le baudrate puis enregistré les valeurs dans l'eeprom (fonction accessible par le menu le la machine)